Widget area in admin area not expanding

If you did not install any plugins then fault is in your functions.php file of active theme. You need to delete last closing “?>” that is closing tag of php. Remove final closing tag of php.

In case if this if happening because of some plugin you need to find out exactly that plugin which is causing this by deactivating plugins one by one, And when you find that plugin which is causing this problem then do the same steps in all .php file of that plugin and remove final closing tag of php “?>”.

source: wordpress.org forums

Unfortunately in my case I already had this ?> removed from my functions.php. So my next move to solve my problem was to disable all the functions; one by one and try to open the widget area. Had no luck with that, so I enabled all the functions in my functions.php again.

Next step was to disable plugins and see if disabling one would result in opening that widget area again. Luckly I don’t use that many plugins and found out that the ‘DMSGuestbook widget’ was causing my problem. Altering the code of that plugin, like Jaytesh Barange mentioned above, would be overwritten with it’s next update.

So for now I disabled the plugin, as it fixes the the problem expanding the widget area šŸ™
Hope to find an answer on it soon.

update:
The author of the plugin, Daniel Schurter, has an answer for it; although I don’t find it a nice one :S

Set ā€œEnable accessibility modeā€ on ā€œAppearance -> Widget -> Screen Optionsā€, that should resolve your problem.
source: dmsguestbook-1-17-1, comment-17972

Favicon

1
2
3
4
5
6
/** FAVICON ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ */
function favicon_link()
{
echo '<link rel="shortcut icon" href="' . get_stylesheet_directory_uri() . '/pix/favicon.ico" />' . "\n";
}
add_action('wp_head', 'favicon_link');

Interesting read on favicons: Understand the favicon by Jonathan T. Neal

1
<link href="/path/to/favicon.ico?v=1" rel="icon"/>